CI/CD stuck

I started a pipeline after some change on my code and the pipeline that worked perfectly some days ago is stuck at this step:

Status: Downloaded newer image for node:14-alpine
 ---> 1d909dafa77f` `Step 2/20 : RUN apk update
 ---> Running in fd86e87502bc

Which shouldn’t take more than one second.

I tried to restart the pipeline at least 5 times.

Also I get the following warning at the start:

*** WARNING: Service runner-z3wu8uu--project-28319448-concurrent-0-1c901511ae8b379d-docker-0 probably didn't start properly.
Health check error:
service "runner-z3wu8uu--project-28319448-concurrent-0-1c901511ae8b379d-docker-0-wait-for-service" timeout

I also created another app on the same pipeline which was stuck on random mavens download but after 5 restarts it completed.

Edit: It succeded after the 7th run. Warning message is still here.

My build got stuck in exactly the same way but the following thread resolved it for me:

Basically, append --network host to the build command, i.e.:

docker build --network host .
1 Like

Thanks for the info. I’ve been experiencing this (since 2021-09-22) as well, be it intermittently, with’s shared runners. Retrying the job eventually made it succeed.

However, I’m (still?) using the Jobs/Build.gitlab-ci.yml template so wouldn’t that need a fix? Or should this be fixed at the runner level instead?

In my case I merely added it to the gitlab ci file. Working directly with runners is a bit beyond me so I wouldn’t know what to suggest there.

There’s an open incident under investigation:

1 Like

Thanks for your answers. I also received this mail telling me that:

my namespace has 30% or less Shared Runner Pipeline minutes remaining. Once it runs out, no new jobs or pipelines in its projects will run.
We recommend that you buy additional Pipeline minutes to avoid any interruption of service.

I found this rather funny as those pipelines just hang doing nothing and I had to cancel them manually. Is there a way to get back those pipeline minutes ?

1 Like

Good question. I hadn’t even thought of that.

Yes, I was planning to ask them directly right after the incident was resolved.