Gitlab docker registry not working

Hi all, I’m probably missing something obvious so would appreciate any pointers!

I’ve got the omnibus version of gitlab working perfectly and I’ve added HTTPS to it and that’s all worked as well.

I then edited the gitlab.rb file to enable the docker registry. I have only changed one line:

registry_external_url ‘

saved the file and done a reconfigure - no errors.

I’ve then created a gitlab project and marked it as a container registry.

on the docker machine I get an error:

[root@docker ~]# docker login
Username: root
Error response from daemon: Get dial tcp getsockopt: no route to host

ping works fine, there is no running firewall on the gitlab host so I’m at a loss as to why I can’t push an image.

And it turns out that I’m daft. I checked the server to see if iptables or UFW was running and they aren’t. I totally forgot that CentOS 7 and higher has firewalld. When I turned that off things started to happen.

Sigh. Oh well, solved - sorry all!