Gitlab image not updating on the internet, but updates on my profile

I’m using a self-hosted gitlab instance, and I have a problem with my profile picture. I have updated it numerous times, and it updates on the website, however, when I use an integration, namely Discord’s webhook integration, or if I send my profile link anywhere, it displays an old profile picture. I’ve tried restarting and everything, yet nothing seems to work. Can anyone help me out?
I’m using Gitlab (self hosted) enterprise edition version 16.10.1.
Old image in the webhook picture:
Old image in the embedded message:
Expected image:

Anyone know how to fix this?

I’m not sure how social card preview rendering works here, but I assume it is a caching problem.

  1. Discord caches the social card preview, and does not immediately call the URL again.
    • To avoid generating load or run into website rate limits.
  2. GitLab social cards could be cached too.
    • You can test and verify that by using public social card validators.

Example for a social card validator, documented in the GitLab Developer Advocacy handbook, added your test URL into the query string.

OpenGraph - Preview Social Media Share and Generate Metatags - OpenGraph

I don’t know how to invalidate the social card caches, though. In this scenario, it seems that the Discord server caches the social card preview.

The thing is, it’s been displaying the wrong picture for about a week now, despite me trying to force it to clear the cache (bringing gitlab down, thereby discord being unable to embed the link and then bringing it back up).
It has to be a Gitlab issue then, right?

Also uh, even if it cached the image, the integration in each individual repository would have to change the image once I change it, yet that’s not done.

Okay it managed to change on the profile link embed, but it still doesn’t change on the integration embed.
When I copy the image link, it directs to this;
Anyways to change that?