Gitlab interaction with git for merge requests is dead

I have my own gitlab-ce copy on my server that I’ve been using for a couple of years. Very low work load. Like 20 repos and a total of 1000 commits over the whole history of that gitlab installation. I use it for my private projects and I add people in my vicinity for discussing code. Everything is as basic as it’s. I never moved it or did anything special. The only special thing in it is that I use apache reverse proxy as a proxy to forward the http interface with tls.

A few weeks ago, gitlab started acting completely crazy and I’d really appreciate helping me troubleshoot this issue. As far as I know, this didn’t come with a specific upgrade or change. My assessment of the issue is that it seems that the asynchronous communication between gitlab and git is completely dead.


  1. Merge requests never see new commits unless I close and reopen them
  2. Merging a merge request never works… it just keeps spinning forever
  3. (not sure about this, as I really don’t remember whether they worked before): Emails don’t work anymore, even when emailing myself locally on the same machine

Even though I’m a developer (C/C++/Rust/Python and a few others), my knowledge in ruby/rails is close to zero. I tried to troubleshoot sidekiq because it seems to be the first culprit, but I found nothing there. Can someone please help me troubleshoot this issue?

Thank you. I understand I’m asking for a lot of someone. But I have no other means to fix this. If you need any logs, please tell me where to send them and I will.