Gitlab pages CI/CD pipeline not working

I have changed the CI/CD pipeline configuration of my repository from SAST to a pages .gitlab-ci.yml and it looks like that this screwed up the pipeline. Regardless how I setup the configuration inside .gitlab-ci.yml, it is always telling me that no jobs/stages are defined if I want to run it manually. It also does not start automatically.

My assumption is, that I do not have to do anything besides having pages activated in the repo configuration. The repo is public, you can check it out here: walters-blog-2.

Does anybody know what is going wrong?


  • What version are you on? Are you using self-managed or

  • Add the CI configuration from .gitlab-ci.yml and other configuration if relevant (e.g. docker-compose.yml)

  • What troubleshooting steps have you already taken? Can you link to any docs or other resources so we know where you have been?

    • The linter tells me the configuration is valid.
    • Copied a working configuration from another repo to check if it runs, but it does not in this repo.
    • I cleaned the runner caches → no effect
    • Tried different configurations with and without stages
    • deleted the .gitlab-ci.yml and created a new one


I figured it out. It was a stupid mistake on my side. If others are hit by that, I document the problem / solution:

Issue was, that I had configured the pipeline in .gitlab-ci.yml like that:

    - master

But there is no branch master. It is main. After changing the configuration to main it worked like a charm.

Thanks to everyone who checked out the issue!

1 Like