Gitlab pages setup in home environment with pelican

Hi everybody !

Rookie question I guess ? For three days now I’ve been trying to set up gitlab pages in my home environment and I can’t get it working, I keep getting a 404 error when accessing it.

Gitlab runs on a docker container, and so does Gitlab-runner.

Server name : http://gitlab.local/
Gitlab hostname : gitlab.local
DNS entry in router : *.gitlab.local
Username : adrien13330
Project name : pelican
Path to page in Gitlab Settings > Pages : http://adrien13330.gitlab.local/pelican
Updated pelican/’s variable SITEURL to SITEURL = ‘http://adrien13330.gitlab.local/pelican

Edited Gitlab.rb with the following informations :

Then I ran the gitlab-ctl reconfigure command

I’m using a basic pelican template cloned from

  • What are you seeing, and how does it differ from what you expect to see?

The project runs fine and I can download the artifact.
In settings the “pages” menu shows up but the link it provides leads to a 404 error instead of the pelican page that Gitlab generated.

  • Consider including screenshots, error messages, and/or other helpful visuals

The only error message I ran into is 404 not found on my browser.

  • What version are you on (Hint: /help) ? and are you using self-managed or

Self-managed Gitlab EE in a Docker container, latest version (13.4.1)

  • What troubleshooting steps have you already taken? Can you link to any docs or other resources so we know where you have been?

I’ve been following the documentation from Gitlab :

Thanks !