Gitlab pages - Stuck on "Something went wrong while obtaining the Let's Encrypt certificate."

Hello,
in my repo setup, under Pages, I have added a new domain. Since I own it, it was pretty easy to verify it.
But for some reasons I really can’t proceed with the let’s encrypt certification… I have tried more than once to remove the domain and to add it back, nothing changed.
And of course I have no clue what the problem is.

Any help would be more than welcome!
Thank you!

Have a look at the troubleshoot section here: https://gitlab.com/help/user/project/pages/custom_domains_ssl_tls_certification/lets_encrypt_integration.md
if you haven’t already.

I’m experiencing the same thing and it didn’t help.

I am also having issues. Verified domain, double checked all the records. I’m using an @ A record of 35.185.44.232. But it keeps failing. :frowning:

I was having this problem with a subdomain. The problem seemed to be a failing CI/CD pipeline and/or a missing folder. The folder I wanted to serve the site from wasn’t in the repo because it was empty and my CI/CD pipeline was failing when it tried to reference the non-existent directory. I could have amended the script in the gitlab-ci.yml config to create the directory but I just made the directory non-empty and committed it instead.