GitLab won't accept changes to 'uploads_storage_path' and 'uploads_directory'


I’m trying to set up gitlab for the first time and I can’t set the storage directories gitlab_rails[‘uploads_storage_path’] and gitlab_rails[‘uploads_directory’]. GitLab keeps telling me “the storage directory [/path/to/my/storage/uploads] (gitlab::gitlab-rails line 81) had an error …”.

---- Begin output of stat --printf=’%U’ $(readlink -f /path/to/my/storage/uploads) ----
STDERR: stat: missing operand
Try ‘stat --help’ for more information.

Now when I switch to user git, I can easily navigate to this path. When I run the exact same command in batch (as user git) I get the following result:

stat --printf=’%U’ $(readlink -f /path/to/my/storage/uploads) = git

I would get the result in the error message if a part of the path was not accessable.

Temporarily I’ve even tried to add all the users that seemed possible (git,gitlab-www,gitlab-redis,gitlab-psql,gitlab-prometheus) to the groups neccessary to access the path and it still didn’t work.

I’d highly appreciate if anybody could tell me the trick to change those configuration values.