HTTP 502 error upon pulling a new version

:hugs: Please help fill in this template with all the details to help others help you more efficiently. Use formatting blocks for code, config, logs and ensure to remove sensitive data.

Problem to solve

I’ve recently gotten an update notice on the admin dashboard.
I run GitLab with docker-compose. So, I ran docker-compose pull, and then docker-compose up -d.
Usually, this throws an Nginx 502 error, then transitions to the Gitlab 502 that says Gitlab is booting, and then boots after a while.
This time, it just remains at the Nginx 502, and refuses to boot up properly. The docker container says that the container’s status is healthy, yet the Nginx 502 error is present.
This isn’t an Nginx issue, because when I go to my server’s IP and port on the web browser, it just infinitely loads, indicating that it’s a Gitlab issue.



Steps to reproduce

  1. Run docker-compose pull
  2. Rebuild your container
  3. Observe the error.


Can’t fetch them due to the nature of the incident.


Please select whether options apply, and add the version information.