I can´t import repositories (Azure Devops) from manifest.xml file

I’m in the research phase to migrate all our Azure Devops repositories to GitLab, there are hundreds of repositories… According to the GitLab documentation, I can use the option of a manifest.xml file, the example structure is very basic, I have tried to use it but I always get an error, no details.

Where can I get a complete example of mass import of repositories, making use of the manifest file?

Repositories aren´t public, so, we will need autentication, how can i do?

Finally work for me. This is because the import process had been failed in authentication to read from an Azure DevOps private repo and we should authenticate against [Personal Access Token] of our Azure DevOps accounts.

Here is the correct manifest.xml which worked for me during the test.

<?xml version="1.0" encoding="UTF-8"?>
  <remote name="AzureDevOps" 
  review="https://username:personalAccessToken@YourAzureDevOpsOrgName.visualstudio.com" />
  <default revision="main" 
  <project path="GitLabProject1" name="TheProjectName/_git/Repo1" groups="TestMigrationManifest"/>