I exceeded the 10GB quota, so I deleted some files but it wont let me push the changes

I have a gitlab free-tier account and this morning I found that we have exceeded our 10GB limit, and so I used BFG to remove them from the history and should now be well under the limit but I can’t push the changes to the repo.

It seems like I need to have the quota temporarily increased, so I submitted a ticket to the support portal but I immediately got a reply saying that the ticket was closed because I do not have a paid account.

Is there a way around deleting the project and creating a new one? I would like to keep all of our issues, wiki pages, code reviews, etc…

I assume you’re using git push -f to replace the branch with the BFG-edited one, and it’s telling you that you exceed the quota? Maybe you can delete the remote branch entirely (or all branches) with git push --delete, and run the gitlab-side “housekeeping”. That should free up the space. Then you can push the new BFG-edited branch(es) back.

I replied to the automatic email asking for help even though I don’t have a paid account and they responded about a day later by lifting the limit temporarily to let me push a fix. :slight_smile:

Might have worked, and would have tried if support hadn’t responded. Thanks for the suggestion!