Installation on Ubuntu 21.10

Unable to install Gitlab on Ubuntu 22.10. Here is the error message I get:

Here are some more details:

  • Linux FMinor 5.13.0-21-generic #21-Ubuntu SMP Tue Oct 19 08:59:28 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

  • Gitlab version - latest

Here is the error message:

100 5933 100 5933 0 0 76064 0 --:--:-- --:--:-- --:--:-- 76064
Detected operating system as Ubuntu/impish.
Checking for curl...
Detected curl...
Checking for gpg...
Detected gpg...
Running apt-get update... done.
Installing apt-transport-https... done.
Installing /etc/apt/sources.list.d/gitlab_gitlab-ee.list...curl: (22) The requested URL returned error: 404

Unable to download repo config from:

This usually happens if your operating system is not supported by
[](, or this script's OS detection failed.

You can override the OS detection by setting os= and dist= prior to running this script.
You can find a list of supported OSes and distributions on our website:

For example, to force Ubuntu Trusty: os=ubuntu dist=trusty ./

If you are running a supported OS, please email []( and report this.

I did try setting os=ubuntu and dist=hirsute as suggested. Still get the same error.

Its not supported on 21.10 or 22.10 only LTS versions. Use 20.04.

Thanks. Will try and post an update here.

22.10 is not released yet (they haven’t even officially begun working on it yet, working on 22.04 that will be an LTS release), I suppose you meant 21.10.

@iwalker has already given the correct answer “only LTS versions”, but if you feel adventurous you can try using the package for the 20.04 (the latest LTS) on your 21.10. It won’t be supported, but it might be less work (it also might be more) than installing 20.04 - I’ve heard success-stories about doing similar things, but I think it’s more for versions right after an LTS (i.e. using the package for 18.04 on 18.10) than for releases 18 months later.

What you should really be doing is for example as 20.04 is the latest Ubuntu Gitlab release, you should be providing those parameters - this is why it failed for you because you need to pretend you are a supported release. So:

os=ubuntu dist=focal ./

I’ve installed Gitlab on Debian 11 Bullseye, and I just had to edit the /etc/apt/sources.list.d/gitlab.list file and change bullseye to buster to get it to work. Which is fine for a test server, if production, then I would leave it on Ubuntu 20.04 or Buster until an official package is released within the near future for versions released after 20.04 like 22.04 or Debian 11 Bullseye.

Thanks for the correction. Yes, I did mean 21.10.

Thanks. I did try with:

os=ubuntu dist=focal ./

and it installed just fine on Ubuntu 21.10.