Raspberry Pi install instruction broken - wrong installer link (404 error)

I was trying to get gitlab up and running on a Pi 4, however the install instructions appear to be out of date.

Instructions: Download and install GitLab | GitLab

Specifically the step that says to run this command to add the apt repo:

sudo curl -sS https://packages.gitlab.com/install/repositories/gitlab/raspberry-pi2/script.deb.sh | sudo bash

FWIW I also tried the path you mention in the Ubuntu docs, as that file does reference Raspbian - that also fails, but later in the setup process:

pi@gitlabpi:~ $ sudo curl -sS https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.deb.sh | sudo bash
Detected operating system as raspbian/bullseye.
Checking for curl...
Detected curl...
Checking for gpg...
Detected gpg...
Running apt-get update... done.
Installing apt-transport-https... done.
Installing /etc/apt/sources.list.d/gitlab_gitlab-ce.list...curl: (22) The requested URL returned error: 404

Unable to download repo config from: https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/config_file.list?os=raspbian&dist=bullseye&source=script

This usually happens if your operating system is not supported by
packagecloud.io, or this script's OS detection failed.

You can override the OS detection by setting os= and dist= prior to running this script.
You can find a list of supported OSes and distributions on our website: https://packages.gitlab.com/docs#os_distro_version

For example, to force Ubuntu Trusty: os=ubuntu dist=trusty ./script.sh

If you are running a supported OS, please email support@packagecloud.io and report this.
pi@gitlabpi:~ $

Any chance someone can update the docs with the correct details?


Yes, since the docs are for PI2.

in particular this package for Ubuntu 20.04 arm64: ubuntu/focal/gitlab-ce_14.4.2-ce.0_arm64.deb - gitlab/gitlab-ce ยท packages.gitlab.com

curl -s https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.deb.sh | sudo bash

perhaps that will help get the repo set up, of which you can then do:

apt-get update
apt-get install gitlab-ce

but you will have to follow this guide: Running on a Raspberry Pi | GitLab

and do a lot of configuration to disable a ton of stuff due to the lack of cpu/ram capability.

Actually, I think the problem is that there are no packages for bullseye yet.
The buster packages seem to work fine, though.

So, as the error output suggests, you might try something like:

sudo os=raspbian dist=buster ./gitlab.sh

That worked for me.
(gitlab.sh being the file I curled the shell script into)