Jenkins CI 500 error

Hi Team,

I have updated to latest version of GItlab 10.6.0, and I am facing an issue. I am having Jenkins setup for CI and it used to work perfectly before the update.
After updating GItlab, “Build when a change is pushed to GitLab. GitLab CI Service URL: http://192.168.0.189:8080/project/xxx” is no more working whenever someone commits in the repo. Though the Manual building Build on Jenkins is working properly.
I even went to Webhook of the project in Gitlab and on clicking on “Test” it gave me 500 error.

Note:

  • Both Gitlab and Jenkins and its plugins are updated to the latest version available.
  • Jenkins Server: http://192.168.0.189:8080

Please Help!!

1 Like

Fixed by allowing “Allow requests to the local network from hooks and services” in setttings

1 Like

Funny. 500 internal server error for a thing like this.
Why it does not say “Request to local network are not allowed. Check in setting page if you want to allow requests to local network.”

BTW: The error in gitlab logs says URI::InvalidURIError

It should have thrown the same error to make troubleshooting easy, it took me 5 hrs to figure out the reason. Hope dev takes this into consideration.

1 Like

As a paying customer w. an on-premise install we are very unhappy about this.

Their answer to a security vulnerability that would only be an issue if bad actors had admin access to our on-premise gitlab instance is to turn off webhooks in an upgrade w. no mention of this in the release notes, then to make us turn them back on and (I suppose legally) accept for ourselves the risk.

Additionally the poor qa evidenced by getting a 500 error when we tried to “test webhooks” doesn’t give us a warm-fuzzy feeling about the quality of the product.

And nothing in the release notes to mention this and nothing in the gitlab blog. Really disappointing.

2 Likes