Jira integration not working

I’ve been trying to integrate Jira using the official guide https://gitlab.corp.firefly.ai/help/user/project/integrations/jira

This command work fine curl -s -u noone@example.com:API_TOKEN https://company.atlassian.net/rest/api/2/issue/GT-1/transitions, I’ve tried both API token and password and both work.
However the same credentials and any transition ID I’ve tried just result in “Test Failed” message and this extremely helpful log message:

  "severity": "ERROR",
  "time": "2018-11-01T06:26:54.751Z",
  "service_class": "JiraService",
  "project_id": 20,
  "project_path": "Compant/my_project",
  "message": "Error sending message",
  "client_url": "https://company.atlassian.net/rest/api/2",
  "error": ""

I’ve run the command above from the server running GitLab and there are not issues.

Even if I hit “Save anyway”, besides linking to the Jira issue in the commit message, smart commit don’t work and GitLab doesn’t comment on the Jira issue.

I’m using my own user in Jira Cloud, with admin permissions, to test the integration.

Hi azelezni

I’m facing the same problem, have you been able to resolve the issue ?


I have the same issue. Did anybody solve this ?

I have the same issue. Gitlab CE 12.5. Any update ?