Last commit and Last update stuck at "loading"

Upgraded Gitlab on premises to 15.8.1

When opening Repositories which have more than a few files, some of the files get a “loading” message only for “last commit” and “last update”

Tried with different accounts from different computers, same behavior. Repositories with “low” amount of files are fine, but if the repository has more than 20 files, this happens.
Anyone else having this issue?

1 Like


I’m not seeing this problem on my instance. What’s your VM specs? CPU? RAM?

1 Like

Thanks for your reply, CPU has 4 cores assigned to it and RAM is 16GB. Was able to narrow the issue down, I can upgrade up to version 15.5.7 with no issues. If I upgrade to version 16.0 or later I start getting this issue.

I setup a test server and upgraded it to the latest version, and it has no issues, so I’m not sure what could be the issue in the main server.

1 Like

Can you run:

gitlab-psql --version

on your main server? I expect unless you haven’t upgraded postgresql, that it will be version 12. The new test install would have been postgres 13 by default, especially for versions over 15.6.0 and higher. I believe postgres 13 to be quicker. At least that’s my experience on my installs both production and lab/test.

If you noticed immediately after upgrade to 15.6 and higher, maybe background migrations were still being ran on the server, which would have meant higher CPU usage for postgres during this time.

1 Like

I had to leave it at 15.5.7 for now since people were going to start using it. If I run the “gitlab-psql --version” command, it currently says “psql (PostgreSQL) 12.12”.

I had waited until all background migrations finished, checked and CPU and RAM seemed ok, so not sure what could it be.

When I was testing 15.6.0 (and above) I also did a service restart and a server restart, but the issue wouldn’t go away.

Thanks again for your response.