LDAP Configure mistake?

Dear Team,

I have try to configure LDAP (AD) by following the Document in Gitlab, here is my setting

gitlab_rails['ldap_enabled'] = true
 gitlab_rails['ldap_servers'] = YAML.load <<-'EOS' # remember to close this bl$
 main: # 'main' is the GitLab 'provider ID' of this LDAP server
     label: 'i-bitz ADS'
     host: ''
     port: 389
     uid: 'sAMAccountName'
     method: 'plain' # "tls" or "ssl" or "plain"
     bind_dn: 'CN=Gitlab LDAP,OU=Gitlab,DC=i-bitz,DC=local'
     password: 'P@ssw0rd'
     active_directory: true
     allow_username_or_email_login: false
     block_auto_created_users: false
     base: 'CN=Users,DC=i-bitz,DC=local'
     user_filter: ''
#     ## EE only
#     group_base: ''
#     admin_group: ''
#     sync_ssh_keys: false

On login menu come correctly but it shown error when try to login as following

Could not authorize you from Ldapmain because "Invalid credentials".

What’s missing in setting?

Thanks in advance,

did you ever get this figured out? My situation is a little different in that I get a 503 when I run gitlab-ctl reconfigure. I cannot find anything in the logs and have no idea how to proceed. Ready to dump gitlab and go to gerrit.

I tried to do GITLAB -> AD (via LDAP) to work and it would not work - I did hear a couple of comments that LDAP authentication against AD was not possible.

However, the good news is that SAML authentication is available and works wonderful. If that’s an option for you use that.