Merge requests approval

Hi everyone,

I am using gitlab free self-managed 14.0.2 version and trying to enable “Merge requests approval” setting.
I guess in 14.0.2 it should be enabled by default(?), but I can’t see it anywhere. I also tried to enable the approval_rules flag from gitlab-rails console and restart the gitlab instance, but that didn’t help either (after restart I checked that the flag is enabled).
Both project and instance settings has no Merge Requests (MR) approval menu in it.

Found some topics, which says I need a Premium subscription for the MR approval feature to appear, but the documentation says it is available for free self-managed 14.0 versions of gitlab:

What am I doing wrong?
Thanks a lot in advance :slight_smile:

Hey @sgalichenko,

I’m getting the same understanding of documentation (and issue) as you, did you find a solution since then ?

Would really like to be able to enable “Reset approvals on push” but can’t find any MR approvals menu at all.

Thanks for your help !

Hi @simneu,
It seems to be a documentation mistake.
If I switch to 14.1 or 14.2-pre on documentation page I see it says that Merge request approval rules works only with premium, while on 14.0 it says all tiers.

Thanks for your answer!

True indeed, but that’s only the case for the “approval rules” part, not for “approval settings” one. I’m not sure what option you wanted to use, but for myself I just wanted to use “Reset approvals on push” from “approval settings” (which is still shown as “All tiers” for 14.1 and 14.2-pre).

I think I’ll try to upgrade to 14.x when I get the time to, cause still running 13.x on my side.

Ah, I see :thinking:
I’m now using the latest production ready version 14.1.0 and there is still no Merge request (MR) approvals menu… :slightly_frowning_face:

There are also some features you can turn on and off from gitlab-rails console called approval_rules/approvals/approval_settings(?). See this doc page:

NOTE: Note: Prior to 12.0, if you are running a self-managed instance, the new interface shown on this page will not be available unless the feature flag approval_rules is enabled, which can be done from the Rails console by instance administrators.

Though it relates to version 12.0 I tried to enable those features anyways and restart an instance, but still no luck.

Yeah also tried the same thing, but I think that’s indeed normal that it does no effect because we can read here: Merge request approvals | GitLab

[…] and feature flag removed in 12.0.

This means that technically the feature should now be enabled by default, without having to set the feature flag (because it was removed).

Really confused why we can’t see the option, I’m thinking it’s probably a documentation mistake. :thinking: