Moving Gitlab to a new server (from centos6 gl6.9.2 source to centos7 gl7.11 omnibus)

Dear Friends,
After Lots of tries I became hopeless, I really need help.
what have I tried so far:

  1. upgrading the current installation to 7.11, backup and restore to the new server - apparently, you can not move from source installation to omnibus.

  2. i tried installing 6.2.9 omnibus on the new server - it does not support centos 7

  3. i tried source install on centos7 - also doesn’t work

the most i’ve accomplished is installing 7.0 update over the 6.2.9 - and the ruby update was hell.

so my question is, is there a manual way to copy all the content from one server to another?
have anyone done it before?

please help me, after weeks of tries i am really hopeless,
many many thanks in advance!

I understand that you have an installation from source, so, the usefulness of the following will depend on whether the database used by the source installation is the same as that used by the Omnibus installation. If they are the same, then this might help. My installation is also not concerned with web hooks or email.

I’ve just completed moving Omnibus Gitlab 6.5 using MySQL to Omnibus Gitlab 7.11.4 using Postgres on Ubuntu 14.04.

The strategy was roughly:

  1. Convert the MySQL database to Postgres using
  2. Do a fresh install of the latest Omnibus package on the destination server
  3. Import the legacy database into the new Omnibus instance*
  4. Copy legacy repositories into /var/opt/gitlab/git-data/repositories**
  5. Run the reconfiguration tool: sudo gitlab-ctl reconfigure
  6. Run the check tool: sudo gitlab-rake gitlab:check and fix any reported issues
  7. Run the database migrations: sudo gitlab-rake db:migrate RAILS_ENV=production
  8. Recreate satellites by running: sudo gitlab-rake gitlab:satellites:create
  9. Regenerate ssh keys by running: sudo gitlab-rake gitlab:shell:setup
  10. Run the reconfiguration tool (again): sudo gitlab-ctl reconfigure
  11. Restart Gitlab: sudo gitlab-ctl restart

*My system user for accessing the database is “gitlab-psql,” but my database, tables, and sequences are all owned by “gitlab”
**The repositories should be owned by the “git” user

The gist here is that if you have a good legacy database and a clean install of the latest Omnibus, you should be able to do it. The “gitlab-rake gitlab:check” command is your best friend here and can be run at just about any point during the upgrade. Omnibus also installs all the appropriate dependencies for you, so, no more time wrestling with ruby updates, etc.