My GitHub Desktop is not able to authenticate with GitLab.com

I have tried to clone a repository in the Github from a link of my project in GitLab, but every time I try it, i’m greeted with a, “cannot authenticate with Gitlab.com, please enter correct password and username and try again,” message even though I have also tried making a PAT. it doesn’t want to take anything and I need this to work but it seems something is heavily bugged and I need a solution please.

Can you share the CLI commands or UI screenshot steps you are doing? I’m not sure if I follow with the steps in GitHub and GitLab. Thanks :slight_smile:

Thanks, to summarize: You are using GitHub Desktop and want to import a GitLab project from GitLab.com. I’ll edit the title.

Did you manage to create a Personal Access Token in your profile, and use the token as the password? How does the clone URL look like?

How to use Github Desktop with Gitlab Repository - devopszones describes the steps with more screenshots for example.

Oh yeah, its the first thing I did but still never worked, and I don’t know if I can share my link for personal work reasons and college, but the URL does end in .git

Is the format using HTTPS https://gitlab.com/user/project.git or SSH git@gitlab.com:user/project.git? Might be worthwhile to verify with git clone on the CLI.