Problem cloning GitLab Repositories with Github Client


I tried to fix the problem myself but was not successful. :frowning:
I want to clone several repositories with the GitHub client from 3 different GitLabs on Windows. For this I used this tutorial here:

  1. I created a SSH Key pair and added the public key to all my profiles on the different GitLabs
  2. I created the access token on each GitLab
  3. When I try to clone the repositories via https and ssh I get an “authentcation failed” instead of being asked for the GitLab credentials


Is there something I missed?

My troubleshooting steps:

  1. Logout from GitHub
  2. Delete my GitHub Credentials in the Windows Credential Manager
  3. Uninstall and Reinstall Github Client

To help find the cause of the issue, I will suggest to :

  1. verify that accessing the repositories through SSH is enabled. For example, for HTTPS, the repository URL is in the form of : https://gitlabURL/repo.git . With SSH it is git@gitlabhostname/namespace/projet.git
    The availability of HTTPS or SSH URL is set at the server level (on premise Gitlab installation) under Admin Area > Settings/ Visibility and access controls.

  2. Try doing the clone from the command line directly with git to ensure the issue is not related to Github client?

Let eliminate these possibilities and see further.


thanks for the reply.

On 1: I’m sure that this should work on alle three GitLabs because others use it directly via Git or also with GitHub Client.

On 2: This works. I tried it with all three GitLabs:

So it works now.

Here are my steps:

  1. Generate different SSH Keys to each GitLab
  2. I followed this tutoials to modify the git config
  3. Clone all repositories via command line and via HTTPS. When asked for credentials insert user name and access token
  4. Open Github Client and add repositories as existing repositories
  5. Try to fetch origin and reenter the same credentials you used before for every repository
    (6. Login to GitHub to use your repositories there)
1 Like

Thank you for providing the steps you took to solve this, @eTx23! :blush: