[Solution found, bug/FR?] How to rename Snippet?


I was originally going to post about how I couldn’t figure out how to rename a snippet but while typing up a question and listing what I’ve tried, I figured it out. It doesn’t seem super obvious in my opinion so I wanted to share how I’ve managed to change the title and instead inquire about others’ thoughts about it to see if it seems obvious to the community (perhaps I’m just a dummy).

  • This is on the big, official instance (gitlab.com)
  • For discussion assume no mods are installed
  • I just created the snippet a minute prior to attempting to change the title
  • Reproducible
  • I’ve tried going to the snippet page (https://gitlab.com/-/snippets/{id}) while logged in and clicking the “edit” button but the edit button doesn’t allow me to edit the title. Edit button is shown below:

At this point it dawned on me to just manually append “/edit” to the snippet URL (https://gitlab.com/-/snippets/{id}/edit) and this worked perfectly. I changed the title, click “save changes” and the title of the snippet had indeed correctly updated. Edit button on the snippet page still refuses to allow me to change the snippet title.

What do you think? Could this be an area for GitLab to improve upon?

Also - should this be a bug report or feature request?

I think I found the code responsible for this behaviour:

If this issue troubles anyone else, I would gladly write a browser mod to change this. Unfortunately I’m too unfamiliar/unconfident with GL’s codebase to write a PR.