[SOVED] GitLab Omnibus upgrade fails due to PostgreSQL update


Today I ran an system upgrade on my Ubuntu machine - which included an upgrade on the omnibus package. sudo apt-get upgrade finished with errors during configuring the ombinus-package, leaving it unconfigured. The error/warning message is

Checking PostgreSQL executables:gitlab: GitLab now ships with a newer version of  PostgreSQL (9.6.1), and will be used
gitlab: as the default in the next major release. To upgrade, RUN THE FOLLOWING COMMANDS:

sudo gitlab-ctl pg-upgrade

I did as instructed: Ran sudo gitlab-ctl pg-upgrade. Unfortunately, this did not lead to success because the updater could not connect to the PostgreSQL server. Which is kind of plausible in my opinion, since GitLab is not running and GitLab (at least the omnibus package) has it’s built-in PostgreSQL server, if I am not mistaken. The problem is: I cannot run GitLab as long as it not configured and I cannot configure GitLab as long as it is not running.

Am I missing something? Is there a way to fire up only PostgreSQL server in GitLab omnibus to perform the database-uprade?

Thanks in advance for any help and please let me know if you need further information!
Best regards - Jonathan

[SOLVED] Seems like I was affected by this bug: https://gitlab.com/gitlab-org/omnibus-gitlab/issues/1990

The PostreSQL configuration for the new version was already compiled by gitlab-ctl reconfigure before the version was upgraded. So removing the line that was breaking the config (max_replication_slots ...) made PostgreSQL working again so I could start gitlab and perform the database upgrade sudo gitlab-ctl pg-upgrade. The latter includes the reconfigure part, so the removed line in the postgres-config is added again afterwads.