SSH keys not showing & get "GitLab: Deploy keys are not allowed to push code."


new user to gitlab here. i have previously been on github as

so my question is about problems with saving & using ssh keys for my own computer & web host server (into which i can ssh connect). i thought i had put in two ssh keys to through their web interface, one for the ~/.ssh/ on my home desktop computer, and one for my web host, into which i can ssh connect. however, after doing all that, i try to push to my repository, and it keeps saying GitLab: Deploy keys are not allowed to push code.

so after getting that, i went back to look at my ssh keys on to see what might be wrong at, and suddenly, neither of my two keys i had put up there was there. gone completely! i logged out and back in, still did not see the two keys i had input under

this was strange, to say the least, so i tried putting the key in yet again for my web host server so i could push from there, and it says:

**The form contains the following errors: **

  • ** Key has already been taken**
  • ** Fingerprint has already been taken**

… even though the two keys no longer show up at all at

so can anyone please help me as to what is happening here why doesn’t show the two profile keys i had all ready input, added and saved there (or so i thought)? why does it say, “• Key has already been taken • Fingerprint has already been taken,” when i try and add them again when they are not showing? why am i getting, GitLab: Deploy keys are not allowed to push code, even though i have added the ssh keys into my profile here at please advise.


— faddah
portland, oregon, u.s.a.

hi all,

well, it took a number of weeks, but this issue, as well as getting a fatal: unable to create thread: Resource temporarily unavailable when attempting to git push from a web host server (Hostgator), were solved on this support thread for, here — .

just as a note, i kind of find it telling that this community forum support request just let this post languish here for weeks, without even bother to trying to help or respond. if you want to compete against the monster in the industry, GitHub, or BitBucket or anyone else, you really have to step up the game in being responsive. and taking what was found in that support ticket above and making very searchable in your support knowledge base & FAQs would be a good start. also, at least responding and keeping alive forum posts like this one until resolution, especially because others here have seen the same thing (i searched), would be a good step in the right direction.


— faddah
portland, oregon, u.s.a.