SSL certificate expired - Gitlab not accessible

In my Gitlab server the SSL x509 certificate is expired and now I am not able to access Gitlab.The certificates aren’t Let’s Encrypt since that is disabled but I think they are self signed SSL certificates.

This is what I get

I try to troubleshoot but until now I have the expiration date:


OIP (6)

I want to know if you have had the same problem and if yes how did you solve it.
I can provide more information if you can let me know what is needed,the documentation for this topic online was limited.

I can generate a new self signed certificate,but I would want an accurate opinion by someone who has had the same problem.

Thanks!

I tried to regenerate the certificate and the key but Let’s Encrypt is not used.

Except that I tried to reconfigure Gitlab by adding the off option for SSL but it didn’t work either

If the certificate has expired, you need to generate a new one. There’s plenty of howto’s on the internet to do that for Apache/Nginx, etc. Here is one I found from google: How To Create a Self-Signed SSL Certificate for Apache in Ubuntu 16.04 | DigitalOcean

Some others more specific to Gitlab: generate self-signed certificate gitlab - Google Search

Eg: Configuring a self-signed SSl certificate - #5 by marshel-savarimuthu

1 Like