SSL Certificate expired // Haskell Transformers Package // Nix

attempting to build GitHub - dktr0/estuary: Platform for collaboration and learning through live coding using Nix. When building, i get an error message saying

fatal: unable to access "":SSL certificate problem: certificate has expired

I have tried every workaround possible - Seems to be an issue with the server as this issue also happens on other peoples computers. This error happened using Nix 2.7 as well as 2.2.2. It occurs on OSX, Ubuntu and Debian.

Any help would be much appreciated. thank you.


Visiting this link: Glasgow Haskell Compiler / Packages / transformers ยท GitLab

shows that the certificate is valid until May 2022. So maybe it was a temporary problem? See if it works for you now, the server uses LetsEncrypt so probably they fixed it in the meantime.

Either way, that Gitlab installation has nothing to do with Gitlab, other than the name of the product running on the server. The domain and Gitlab server installation is managed by someone else (Glasgow Haskell), so nobody on this forum can help with that. You would need to contact Glasgow Haskell directly about it.


Thanks for the thoughtful reply. This has been an ongoing issue for a few weeks now. I will try to contact GHC.