Suddenly getting push errors


I have been using GitLab and SourceTree for a while now with no issues. However, just yesterday I started getting an error that seems to be related to the SSH key setup. The last time I tried pushing was about a week ago, and it worked fine then.

I get the following error:

"git -c diff.mnemonicprefix=false -c core.quotepath=false push -v --tags origin master:master
Pushing to**********/***********.git
FATAL ERROR: Disconnected: No supported authentication methods available (server sent: publickey)
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

Pushing to
remote: GitLab: You are not allowed to push code to protected branches on this project.
! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to '

Completed with errors, see above."

Any help would be appreciated

This looks like someone enabled branch protections for the branch you’re trying to push to. If you have access to the project settings you can disable this (though I wouldn’t recommend it, someone probably enabled it for a good reason). Also consider asking other team members if they did it and why?

See the docs for this feature:

If you want to push code to a protected branch you need to either have permissions to do so directly or you need to open a Merge Request for it.