Ubuntu 22.04 (Jammy) / GitLab CE 15.5.0

Dear,

I currently try to install a personnal server and I want to have GitLab on it.

The characteristic of this PC is :

  • Intel Celeron(R) N4000 CPU @ 1,1GHz x 2
  • SSD 500Go
  • RAM 8Go

And it’s a fresh install of Ubuntu 22.04 (Jammy)

I installed GitLab CE 15.5.0 (https://packages.gitlab.com/gitlab/gitlab-ce/packages/ubuntu/jammy/gitlab-ce_15.5.0-ce.0_amd64.deb)

  • script
  • install (sudo apt-get install gitlab-ce=15.5.0-ce.0)

I just reconfigure GitLab without any change into the gitlab.rb file.

All was OK and i’m able to access to GitLab signup page using http://localhost:8080

But when I log in with the root account, a 404 page is display.
And when I change the url address with “http://localhost:8080/root”, I only have a withe page with a header.
gitlab

A couple of years ago, I lready had install GitLab without problems on this same PC.

The "gitlab-rake gitlab:env:info return this :

System information
System: Ubuntu 22.04
Current User: git
Using RVM: no
Ruby Version: 2.7.5p203
Gem Version: 3.1.6
Bundler Version:2.3.15
Rake Version: 13.0.6
Redis Version: 6.2.7
Sidekiq Version:6.4.2
Go Version: unknown

GitLab information
Version: 15.5.0
Revision: cf72b36d5fa
Directory: /opt/gitlab/embedded/service/gitlab-rails
DB Adapter: PostgreSQL
DB Version: 13.6
URL: http://gitlab.example.com
HTTP Clone URL: http://gitlab.example.com/some-group/some-project.git
SSH Clone URL: git@gitlab.example.com:some-group/some-project.git
Using LDAP: no
Using Omniauth: yes
Omniauth Providers:

GitLab Shell
Version: 14.12.0
Repository storage paths:

  • default: /var/opt/gitlab/git-data/repositories
    GitLab Shell path: /opt/gitlab/embedded/service/gitlab-shell

And I don’t have any idea how I can solve the problem.

Hi Yannick,

did you try “the usual stuff” like:

Different browser,
Deleting cookies, Force reload ( F5), Debug F12 in Firefox
Private browser window

best,
Bodo

Hi,

Thanks for your help.

I didn’t check with another browser for the moment.

Deleting cookies, force reload (F5) on private window with Firefox change nothing.

But using Debug in Firefox show me many errors/warnings.
I will try to search into this way.

Hi,

Image and script files are correctly placed into “/opt/gitlab/embedded/service/gitlab-rails/public/…”.

And I’m not able to open a “.html” (as 404.html) file into firefox.

I will try with another browser.

Hi,

Same result when using Chrome browser.

But I think I do a little step more (I hope) because I’m able to open the “404.html” file that i’m don’t with Firefox.

After a lot of research, the native Firefox browser is a snap application on Ubuntu 22.04 which use a sandbox so it can explain the impossibility to open the file.

Hi,

I think that the problem is on nginx webserver.

I tried to do some modifications on the “/opt/gitlab/embedded/conf/nginx.conf” but without result :sob:.

Error into DevTools on Chrome for the signin page :

Refused to apply style from ‘http://localhost:8080/users/sign_in’ because its MIME type (‘text/html’) is not a supported stylesheet MIME type, and strict MIME checking is enabled.
Refused to execute script from ‘http://localhost:8080/users/sign_in’ because its MIME type (‘text/html’) is not executable, and strict MIME type checking is enabled.

Always no solution

Nobody install Gitlab CE on Ubuntu 22.04 ???

Most likely the problems are due to what you configured in /etc/gitlab/gitlab.rb. Gitlab normally runs on HTTP port 80 or HTTPS port 443, and you have configured it for port 8080?

Please explain what changes you made to gitlab.rb file?

There is no reason for it not to work, providing that you followed Gitlab documentation correctly for the installation process.

Also you should know, Gitlab needs minimum 4cpu, so your hardware specs don’t meet the minimum requirements.

Hi,

I did no changes into the “gitlab.rb” file.
I just installed GitLab CE and reconfigure it using the “gitlablab-ctl reconfigure” command.
Ubuntu is also a new installation, without any modifications or installations before trying to install GitLab.

Even if the minimum hardware requirements need 4 cores, I have already installed GitLab on this PC but i was with previous versions of Ubuntu and GitLab (I don’t remember the versions).

What is your external_url configured to in gitlab.rb? This is an absolute minimum for configuring Gitlab. You say you made no changes, but this is something that must be configured. This is why I ask why you connect on port 8080, when normal connections are port 80 or 443. So either you are connecting wrong, or configured external_url to use 8080.

Please provide more info, and explain exactly step-by-step on how you installed your Gitlab installation?

I’m working on finishing up a setup of GitLab CE on Ubuntu 22.04 (but it was installed using the focal packages, because there was no jammy packages back then, but we knew they were coming so we didn’t feel a need to be careful on that account). I haven’t had any problems that look even remotely like yours (the problems I’ve had was with other parts of the setup, e.g. the load balancers in front).
I think the the help/questions you’ve been given/asked by @iwalker are sane, so please answer that.

So, I decided to make an Ubuntu 22.04 Gitlab installation. I followed the instructions as written here: Download and install GitLab | GitLab

As you can see from my console history on the new server that I have made you can see it exactly follows what was written in the documentation:

1  sudo apt-get update
2  sudo apt-get upgrade
3  sudo apt-get dist-upgrade
4  sudo apt-get install curl openssh-server ca-certificates tzdata perl
5  sudo reboot
6  curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.deb.sh | sudo bash
7  sudo EXTERNAL_URL="http://gitlab.local" apt-get install gitlab-ce
8  sudo cat /etc/gitlab/initial_root_password

and to verify the actual version of Ubuntu:

gitlab@gitlab:~$ lsb_release -a

No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 22.04.1 LTS
Release:	22.04
Codename:	jammy

gitlab-ce package verification to show I installed the 22.04 one:

gitlab@gitlab:~$ apt info gitlab-ce
Package: gitlab-ce
Version: 15.5.1-ce.0
Priority: extra
Section: misc
Maintainer: GitLab, Inc. <support@gitlab.com>
Installed-Size: 3065 MB
Depends: openssh-server, perl
Conflicts: gitlab-ee, gitlab-fips, gitlab
Replaces: gitlab-ee, gitlab-fips, gitlab
Homepage: https://about.gitlab.com/
Download-Size: 1146 MB
APT-Manual-Installed: yes
APT-Sources: https://packages.gitlab.com/gitlab/gitlab-ce/ubuntu jammy/main amd64 Packages
Description: GitLab Community Edition (including NGINX, Postgres, Redis)

N: There is 1 additional record. Please use the '-a' switch to see it

Screenshots of my new installation, so that you can compare with your original post.


As you can see, everything works correctly, so the only reason yours is most likely not working is because it wasn’t installed and configured properly as per the documentation. Otherwise, my installation would also have failed.

Either that or you are accessing it incorrectly over port 8080 when you should be using port 80 or 443 if using HTTPS. Maybe try http://localhost if you are connecting locally, but easier is to verify /etc/gitlab/gitlab.rb and check what value you gave external_url.

2 Likes

Hi,

Sorry to reply so late but I was a problem with my internet connexion.

I did a fresh install as you mentionned and it’s working.
The problem was actually due to the port 8080.

Thanks a lot for your help.

1 Like