Unable to renew Let's Encrypt certificate on Pages

Let’s Encrypt Page - unable to obtain certificate

ACTION REQUIRED: Something went wrong while obtaining the Let’s Encrypt certificate for GitLab Pages domain

  • My GitLab page was running for a few months already and it was working fine. In a past a certificate was retrieved without any issues. I didn’t change anything.
  • I clicked verify on the domain and it works fine.

Domain with issues is funwithcloud.com

How can I troubleshoot this issue since I have zero access to logs?


it may have solved itself already, I can access your domain just fine.


Hi, since this topic appears first in the search results for “something went wrong while obtaining the Let’s Encrypt certificate”, i wanted to share my solution to this problem, which turned out to be caused by lack of index.html file in my /public directory, and my _redirects file. You see, I wanted the root of my page (example.com) to redirect to one of subdirectories (example.com/en/index.html), so I removed my index file from the /public directory and set up a _redirects file containing this line:
/* /en/index.html
It kinda worked, but after this change I would get problems with Let’s Encrypt certificate renewal, so I cancelled it and now it’s working again.

1 Like