Upgrade Gitlab Helm chart from 3.3.2 to 4.0.0... backup is extremely small

I’m currently following official documentation to upgrade my GitLab Helm chart from 3.3.2 to 4.0.0.

I have run a manual backup that is 1.9 GB (with backup-utility) just in case my upgrade processes goes awry. I have had to restore GitLab from one of my backups of this size and it has worked perfectly. However, in the 4.0.0 upgrade guide, when I run:

curl -s https://gitlab.com/gitlab-org/charts/gitlab/raw/v4.0.0/scripts/database-upgrade | bash -s -- -r gitlab -n default pre

I only get a backup in AWS S3 of 10.8 MB. I guess I’m expecting it to be bigger. There was also a time before this when the backup was only 10 KB. I tried to restore from that but GitLab threw a bunch of errors that I forgot to keep record of. So, I don’t want to go further down this upgrade processes unless I for sure am supposed to get a backup of only 10.8 MB.

This is the output I get from running the above command:

Unable to use a TTY - input is not a terminal or the right kind of file
2020-07-25 15:39:35 +0000 -- Dumping database ... 
Dumping PostgreSQL database gitlabhq_production ... [DONE]
2020-07-25 15:39:40 +0000 -- done
Packing up backup tar
WARNING: Module python-magic is not available. Guessing MIME types based on file extensions.
[DONE] Backup can be found at s3://fw-gitlab-backup-storage/database_upgrade_4_gitlab_backup.tar

I’m not sure if the python-magic warning is something to care about or not.

Ultimately, my question is, what is wrong with my backup and/or configuration? I can’t think of anything that I’m doing wrong to get a backup so small.