Using group applications to authenticate users lead to internal server error


I’m using to authenticate the users in an application I manage. I’ve been using user owned applications (applications declared in my personal settings for months, since this was the only kind of applications available, and it worked fine.

With the release of group owned applications (applications declared in a group settings, I tried to switch from my user owned applications to group owned applications. However, despite the fact that I configured the group owned applications exactly as my user owned applications was configured, I didn’t managed to make them work. Each time my application redirects me to to authenticate me, I get a 500 internal server error from GitLab.

Did you manage to make group owned applications work? Do you have an idea what can be wrong with my setup?


I can confirm the problem. Tried to setup Oauth, using a group application, got an error 500 on the page***&response_type=code&scope=read_user%20read_api[...]

but using an app on my user, with the exact same parameters, no errors.

The problem seems to have been fixed.