Web IDE gives error (Branch master was not found in this project's repository)

Web IDE is not working and only give error message

Problem description:

  • What I am seeing= After clicking on the Web IDE button in any of my project repos i get a screen that say “Branch master was not found in the is project’s repository” and how does it differ from what you expect to see?

  • What I expect to see? = i expect the Web IDE to start up and show me the code/files

  • *Here is a screenshot of the repo readme before i click on the Wed IDE button =


  • Here is a screenshot of the issue after i click on the Wed IDE button =


  • *What version are you on = 12.8.6-ee ? and my gitlab is self managed and is located as a relative path domain/gitlab *

  • What troubleshooting steps have you already taken? = i have viewed the developer tools and found that when i click on the Web IDE button a A 404 will be raised when calling the check_config , i also tried adding accept encoding to my nginx proxy but that didnt work?

1 Like

I have the same issue here. I used a Nginx to redirect to the gitlab system. Not resolved currently…

I just updated to 12.10.1-ee (695c29abcf7) and am now getting this error.
Worked fine on previous version, no changes to gitlab.rb, but I did have to run gitlab-ctl reconfigure, before runsv would start after reboot.

I’ve also got this problem, also proxying from Apache.

Hi all! A similar problem was discussed in WebIDE won't open and the workaround posted there solved the problem for at least one user. Can you please try that workaround as well?

I have that workaround in place as well, same error message. I do notice in the log files when the WebIDE requests the master branch, it’s getting back a 304 not modified, instead of the actual data for the branch, so that datapoint might be helpful.