Weird behaviour with Merge Requests today 29/04 on Gitlab.com

Is anyone else experiencing strange behaviour when working with Merge Requests in gitlab.com today?

I have a merge request that was opened by a dev in my team. However, when I attempted to merge it into main, I had a strange error.

Now the MR is in a wierd state: it does not appear under “open” Merge Requests, and is instead under “All”. The Merge Requests states that the “Merge request is not mergeable. Try again.” and is failing on “Merge request must be open.”. However, if I attempt to use the “reopen merge request” button, it fails and nothing changes and the MR remains in this weird state.

I then tried creating a new MR from the same branch and when I clicked the “create merge request” button, I got a Gitlab.com “500 internal server error”. The MR was created when I refreshed the page, but this second MR is now is the same wierd state.

I also tried creating a new branch in this repo, updating a totally unrelated file and then attempted to create an MR - this resulted in the MR being in the same wierd state as the others.

https://status.gitlab.com/ shows nothing.

I am now stuck and cannot merge anything.

Any ideas?

An issue has been raised here: Merge request marked as "Open" shows message "Merge request must be open." (#458716) · Issues · GitLab.org / GitLab · GitLab

I expect the Gitlab status page will be updated at some point showing this problematic issue.

1 Like

Thanks @iwalker.

I was able to merge this request just now - I think Gitlab did a “bulk” unstick manoeuvre for all the stuck MRs and that worked for me. I need to click “reopen” and this time it worked and then i was able to merge as usual.

1 Like