Why just push a git tag will make pipeline failed

Update 2018.12.17: Problem solved. Check this issue #55424

When I use gitlab ci on gitlab.com, I foud that just put a git tag(no code changes) would make pipeline job failed. I don’t know why. Can you help me to figure it out?

You can see the picture below, the first pipeline success and the second one failed, but their commit hash are the same(545154d4),so the codes in the repo are the same. The only difference between them is that the pipeline #40304452 has a tag with it.

You can see the error log of the failed one in the picture below:

The script that failed is this one:

  • sshpass -e scp -o StrictHostKeychecking=no -P $SRV_PORT ./$IMAGE_TAR_NAME devops@$SRV_IP:/home/devops

I’m sure ALL the variables have its right values, because I didn’t change any things. I just pushed a git tag that triggered the second pipeline(#40304452).

Why a git tag will fail the job? Is that a bug or some thing else?

Please help me with it, thanks a lot.

Problem solved. Check this issue #55424

1 Like