Authentication failed : exit 128 code

hey Everyone,
I tried to import repo from bitbucket to gitlab via URL. i was able to import however getting issues when trying to mirror. i used these scenarios:

  1. used https://username:password@giturl : i was able to mirror repo 1 time then it failed after 3-4 minutes. On other repos i tried this approach and they failed in first attempt

  2. i used http token from bitbucket and used this as link - https://username:token@giturl > when i gave my password with token i got password error however when i gave token in password then i got authentication failed error

Could this be gitlab service degradation?


Was able to do with just https://username@giturl

Bitbucket recently stopped using the Account password for Git authentication and they moved into the App Password which is more secure.

Did you give a try to create app password and then tried the migration? Checkout the article for the Bitbucket Git authentication error

Basically you need to use the account password as shown in the below syntax. Hope this helps.

git remote set-url origin https://<Bitbucket_Username>:<App_Password><Repo_Name>.git

Thanks for your comment. i was not changing remote url. i was just importing project and then tried to mirror.
later on while mirroring where i was having issues i used username@bitbucketgiturl and it did the work of mirroring for me. all good on my side now and mirroring is not stopping. although app password can help in situation when we change our password.
thank you