Boilerplate static site giving 401 despite visibility settings

I’m trying to set up gitlab pages for a static personal website. I am using the cloned static site example with 0 changes. I wanted to first confirm that I could set up the DNS and visit the example page before continuing. I believe I set up the DNS records properly through my provider CloudFlare. You can see I have the domain listed and verified in the settings>pages screen. And under settings, visibility, project features, permissions, I have enabled the Pages setting to allow “Everyone” to view the site. Yet when I visit the URL, I still see the 401 unauthorized screen.

I have googled the issue and found other posts with no real resolutions other than to enable the Pages visibility setting, which I have clearly done. I’m not sure what I could be doing wrong, but any helpful ideas would be very appreciated.

(Please excuse that I wish to preserve the anonymity of my domain)


It seems you haven’t pushed anything, can you please double-check the pipeline was successful?

I’m saying so because you still have the “Configure pages” box, while after you published the website should become “Access pages”, with a URL to a domain (see screenshot):

1 Like

Thank you! I tried pushing some code, and now I’m able to access the site through the domain.

However I am still having problems. When I try to access it through my custom domain it seems to be in a redirect loop. I am seeing ERR_TOO_MANY_REDIRECTS in my browser and the page won’t resolve. Maybe it is a problem with my DNS configuration in CloudFlare. I have only 2 records, <my-custom-domain> CNAME <my-gitlab-username> and the TXT record that I used for verification. It seem the verification I had done a while ago was successful, and my custom domain is now showing up under access pages. I’m not sure if I still need the verification TXT record.

Is the domain a subdomain or a root domain?

Are you proxing it through Cloudflare? Or is it a direct connection?

If it can help, this is my configuration:

1 Like

Thanks for the quick response. It is a root domain. I believe I had it set up incorrectly. I actually just updated my DNS settings again according to the guide here:

and re-set up the page rule (I had one previously configured for my old host), following this:

It’s still not working, but I will give it some time to update and check back later.

DNS records

Page Rules

1 Like