Cannot access to my repositories

Cannot access to my repositories, getting error 500

Today I created a new group and added some repositories on it. After that I decided to delete it, I was just learning how to use the groups functionality.
Another thing I’ve done was the change of the visibility of one of my projects (the one called timer) from private to public.
After one of those operations I cannot access to my old repositories, all the repositories created before today, are not accesible.

I’m using and each time I click to enter to one of my old projects I get error " 500, Whoops, something went wrong on our end" and I should see my repository main page (most of them are public repositories).

I tried to do again all the creation of the group and the repositories inside that group, and then delete the group, but nothing happened, I can’t access to my repositories.

Any idea of what can be causing the error 500 issue when trying to access to any of my repositories created before today?

Linked issues:

1 Like

I have the exact same issue and I created a support ticket for it. Maybe you can try doing the same. (Submit a request – GitLab, Inc.)


I’m really worried about it. I will create a ticket there too.

Same problem here, I’ve just submitted a support ticket.

1 Like

Same problem for me for one repository.

But it is only the front page of the repository that is not working.

Commit and fetch do work. CI is also working.

Confirming that fetch and commit also work on my side. It seems to be a problem only with the front page. I can also access to the settings of the repository with this link:[user-id]/[repository-name]/edit

Just adding this “/edit” at the end of the url of the repository.

1 Like

Have you resolved?

1 Like

Thanks for flagging. The incident is tracked at 2021-08-12: Viewing personal-namespaced projects returning 500s (#5340) · Issues · / GitLab Infrastructure Team / production · GitLab

1 Like

The problema was solved. The Gitlab team worked on the ticket that @dnsmichi linked, and it is working for me.

Thanks everyone.