Changelog via Repositories API ignores configuration on self-hosted instance

When Gitlab 13.9 released, we (well, more specifically my boss :slight_smile:) were quite excited about the introduction of a native way to generate a changelog, but it seems like the configuration is ignored on self-hosted Gitlab.

I was about to post this about two weeks ago, but then it dawned on me to try generate the changelog on rather than on our self-hosted instance (which was at that point still 13.9 and with being 13.10, I figured some fix could have happened) with the same project and there it worked as expected.

Today, after confirming with our admin, that we have indeed upgraded to 13.10, the configuration is still not being picked up, even though the project is the exact same as the one on

I went through the forums and issues and couldn’t quite find anything related to this - which seemed quite perplexing, but I digress - so I was wondering if anyone with their own self-hosted Gitlab could check if it’s working for them before I go file a bug report? Is there something that needs to be somehow enabled?

Thank you, Mikuláš. :slight_smile: