Fresh omnibus installation on Ubuntu 14.04 SSH Fingerprint error

I have created a fresh installation of Ubuntu 14.04 on an Azure VM and then installed GitLab via the omnibus package. Everything works great with the exception of adding SSH Keys. When I attempt to add an SSH Key to a profile via the UI or Web Service I get a “Fingerprint cannot be generated” exception.

No response on this issue?

Can you provide some logs?

Hi I got same error too. It’s omnibus 7.3.2 version

Which log file do you want to look at?

In /var/log/gitlab/gitlab-rails/production.log the key is already in there, and there’s no \n in the key for sure (same key worked using

More over there’s /tmp/gitlab-key-file* created

I checked your source code app/models/key.rb line #89 there’s following

cmd_output, cmd_status = popen(%W(ssh-keygen -lf #{file.path}), '/tmp')

however, the ssh-keygen on my system doesn’t support -lf option. To generate fingerprint it needs -F option

So I override the /usr/bin/ssh-keygen with a script which ignores -lf and force it’s a -F. but still same error.

/opt/SSHtectia/bin/ssh-keygen-g3 -F $2

So anything missing here?

Which logs are needed? I just updated to the latest build and the problem is still there.

There was a bug reported here and a patch that should fix it already got merged

If you still have a problem, open a new issue please.