Gitlab.com returns 403 Forbidden

Hello All,
I have been using gitlab.com for a while now BUT just recentlyI found that i am unable to connect to the https://gitlab.com site. When i try to connect, i get “403 forbidden” returned.
If i plug my pc into another network, it works. It would appear that our public ip address has been banned.
Does anyone know how to fix this issue.
Is there anyone i can contact to get our ip address un-banned?
Thanks
Stuart

bump,
sorry, I still haven’t found a solution to this yet

Im having the same issue since today, did you ever get ever get around it, or did it just start working again after a while ?
Accessing gitlab through my mobile provider still works, but through my home network alI get is ‘Forbidden’ at each request.

edit: Nevermind, just got access again shortly after posting this…

Im having the same issue since today. ¿Why does this happen?. I can’t access gitlab.com from my company’s network.

we experienced the same issue today with a locally running GitLab instance from the official Docker image (with little adaptations to make it work in our proxied environment) - seemingly out of nowhere - and had to restore from a backup.
Nothing suspicious in the nginx logs, and we were not IP blocked by the rack attack config (checked with mobile access and it also didn’t work).

Just got this now, can access from phone and ssh, but not HTTP on the wifi or lan. Seems like a temporary IP block to me. Of course mine hasn’t lifted yet. I use Gitlab all the time… maybe I hit some sort of requests/day limit?

Not sure what’s up here.

=== Addendum ===

Could this be runner related?

Same here. Did you solve this?

This ticket is very old but the same issue happened to me

It seems to be related to docker login / docker push, but perhaps it was just a coincidence

I logged in to our docker registry on-premise, pulled an image and tried to manually push it to gitlab.com, docker attempted to do so, but I wasn’t logged in so it failed. I’ve attempted a docker login, but forgot that I’ve enabled 2FA so the login failed as well. Then I’ve tried to create an Access Token thru the web UI, but i wasn’t able to do so, since any gitlab.com URL returns just “Forbidden”

It seems to work just fine from another IP address so I guess our current IP address got blocked, I’m not entirely sure if it’s due to docker, but it’s possible.

How could we prevent this? We don’t want our entire IP address used by 100+ developers to be blocked from accessing gitlab.com due to a typo or a failed login.

i have same error, ip is banned