GitLab Community Edition 15.10 not integrating with Jira

Describe your question in as much detail as possible:
We are making use of GitLab Community Edition 15.10. We are trying to integrate a client’s Jira account to some of the projects/groups on our gitlab.

I’ve tried to integrate it from Jira side. So when i choose the self managed gitlab option on Jira, I enter the URL and it says “Failed to update the GitLab instance. See the troubleshooting documentation.”

Hopefully noone with power has insisted that we do that yet (our Jira lives in the cloud (and as far as I have understood that is all atlassian sells these days), and our GitLab is too well protected), but because people have asked about it I have read up on it. So if you have a setup where it’s possible (or are ready to make one), it sounds easy.

Have you read

and the relevant links?

I’ve tried both these types of Jira integrations. It’s same issue

Are you trying it with Jira Cloud or the self-hosted Jira Datacenter?
Which installation have you used? Marketplace or manual install?

We are making use of Jira cloud.

I suggest to check the troubleshooting guide. Usually, the problem is that GitLab instance is not reachable from Atlassian, but check all the mentioned prerequisites in the docs.

I have a feeling it’s firewall issue.
Is there a possibility you can try connecting some other jira to it just to see if it connects? if it doesn’t then the issue is on gitlab side, if it does then issue is with jira cloud (which is unlikely).
try stopping firewalld, iptables and disable selinux (as a test) and try connecting, then enable back

Is there any chance that i can just enable a certain port via ufw and try?