Gitlab Pages: 404 for even the simplest setup


#1

Just like in 404 error on Gitlab Pages

I have a super simple setup where gitlab pages is 404-ing on the main page.

Test repo is here: https://gitlab.com/windtrain/pagestest. Dead simple with just an index.html and a ci script to copy the directory to /pages.

Page should be here: http://windtrain.gitlab.io/pagestest, but 404s.

The only distinction I can see is that this is a group page. Not a user page. Other than that, I’ve no idea.

Any ideas?

Thanks

Edit: I’ve just tried an even simpler example, with an uploaded public folder. But have the same result:

Edit 2: I’ve used exactly the same code as previous, but now in my user repo and it works! So I think there is a bug when trying to use group-based pages.

Edit 3: Raised issues for this:


#2

I get same issue.

  1. Forked plain html project https://gitlab.com/pages/plain-html
  2. ran build pipeline
  3. went to settings -> pages and clicked on the link
  4. result = 404.

any help would be appreciated. I have tried both on username and group and result is same 404

Thank You


#3

I can also confirm, though for me both group-based and user-based does not work.

For reference, my repos are at https://gitlab.com/willypillow/plain-html and https://gitlab.com/wppages/plain-html , with https://willypillow.gitlab.io/plain-html and https://wppages.gitlab.io/plain-html showing 404 respectively. In addition, user pages (i.e. https://willypillow.gitlab.io/ ) does not work either.


#4

Reproduced and replied in https://gitlab.com/gitlab-com/support-forum/issues/1460.

User pages works fine.


#5

Is this a new issue? I have a group for which I created the pages some time ago and it was working. Today I’ve created a plain HTML hello-world site for a private project and I only get 404 (deployment is reported as successful, and the “Pages” section in the project says the pages are served)


#6

@axil Unfortunately for me, however, user pages does not seem to work. Could you check the links I’ve posted? Thanks in advance.

Also, I’ve cloned @winderresearch 's repo to another test account at https://willytest.gitlab.io/userpagestest but to no avail.

Thanks.


#7

Still Same Issue


https://qoomon.gitlab.io/ -> 404


#8

Is it maybe just tremendously slow? Today https://jellby.gitlab.io/ChemBioLumRev/ works…


#9

Works for me now. Thanks.


#10

Maybe it’s just slow, but I wasted a few hours debugging because I thought I had messed up somewhere.

In my case, I now have a default plain-html project, set up 4 hours after the bug was marked closed, and the builds were successful, and gitlab says, “Congratulations! Your pages are served under: https://ad8e.gitlab.io/plain-html” but the link is 404 anyway, 4.5 hours after the project was set up.


#11

I am also having the same issue - 404 on a fork of the plain-html repo.
The setting>pages says that the page is being served but it is 404. Has been around a hour.

build log is
Running with gitlab-ci-multi-runner 1.9.0 (82714ae)
Using Docker executor with image alpine:latest …
Pulling docker image alpine:latest …
Running on runner-4e4528ca-project-2351542-concurrent-0 via runner-4e4528ca-machine-1485000998-be78f011-digital-ocean-4gb…
Cloning repository…
Cloning into ‘/builds/mtsdesigncouk/plain-html’…
Checking out ec654dc1 as master…
$ echo 'Nothing to do…'
Nothing to do…
Uploading artifacts…
public: found 3 matching files
Uploading artifacts to coordinator… ok id=9030877 responseStatus=201 Created token=wFDqDqxm
Build succeeded

it is a project page with the default url.
https://mtsdesigncouk.gitlab.io/plain-html

Many thanks!


#12

Yep, the pages appeared today. Either the issues were resolved or the process was just slow. Thanks for everything anyway :wink:


#13

Can confirm that using a fork of the hugo page also fails to show up at the actual address, although the Settings give the desired address. Site was created a couple of hours ago, so I’ll refer back here if it really was an issue with slowness.


#14

Mi pages built process had finished two hours ago. If I try to access the pages url I’m still getting a 404,

Bug?


#15

I’m having the exact same issue. I’ve used GitLab Pages in the past with no issues, but this project doesn’t seem to want to work.

I’ve checked the build runs successfully. I’ve ran it multiple times. I’ve inspected the artifacts left over and they seem fine.

Project: https://gitlab.com/relay_sc/relay-trello-powerup
Test Page: https://relay_sc.gitlab.io/relay-trello-powerup/manifest.json

Figure this must be a bug or something.


#16

Same here, so definitely sounds like a bug. I am getting a 404 for all my pages even though the build has ran fine and all the artifacts look good. Mine is for a private project so won’t bother to post the project link here.


#17

Yeah, it’s just slow. Mine showed up before the 15 hour mark. I encountered a few more bugs and decided to move to github.


#18

Just under 24hrs and still 404.


#19

Issue 1460 seems to have solved the problem by restarting some daemon process that was in a deadlock. From the outside at least, this seems to be a very plausible cause for what is the problem right now.

I’m seeing the 404 for 36h+ right now btw.


#20

Update: I just created a new repo, and it immediately worked just fine. Seems like the slowness issue has been resolved.

EDIT: Custom domain is still giving 404. Gonna give it a few hours and try later…