GitLab Runner on private IP not working

My Gitlab instance running on public network through https protocol. I have configured Group based Gitlab-runner on my private network IP address of our Ubuntu-14.04 system.

Currently under GitLab web instance–>Project–>Settings–>CI/CD–>Runner–>Group section shows enabled.

When I tried to run my CI/CD job it is not executing. It is showing below error message.

This job has not started yet
This job is in pending state and is waiting to be picked by a runner

  1. Our Firewall admin confirmed that https protocol bi-directional access enabled for both of our public gitlab instance and to our Gitlab-runner private machine IP.
  2. On my Gitlab-runner (Ubuntu) system gitlab-runner service running through sudo permission.
  3. Also On my Gitlab-runner (Ubuntu) system, I have added below entry in the /etc/sudoers file.
    gitlab-runner ALL=(ALL) NOPASSWD: ALL

still not working, any assistance on the same would be highly appreciated.

Oh i fixed it . problem was
i edited gitlab-runner then checked this option Run untagged jobs --> Indicates whether this runner can pick jobs without tags.