GitlabCE 13.11.3 upgrade to 13.12.5 running on Ubuntu 18.04 failed - glibc_2.28 dependency


i tried to upgrade my gitlab but it fails

  • first because i had to upgrade to the latest 13 version
  • second because a “glibc_2.28” dependency.
    After this failed try Gitlab was not working anymore. I had to recover a previously created snapshot.

As far as i got it, there is no glibc_2.28 available for Ubuntu 18.04.

Does somebody know how i can resolve this?

Detail Information:

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.5 LTS
Release:        18.04
Codename:       bionic
ldd --version
ldd (Ubuntu GLIBC 2.27-3ubuntu1.4) 2.27
Copyright (C) 2018 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
Written by Roland McGrath and Ulrich Drepper.
cat /etc/apt/sources.list.d/gitlab_gitlab-ce.list
# this file was generated by for
# the repository at

deb bionic main
deb-src bionic main
sudo apt-get update && sudo apt-get install gitlab-ce
Get:1 bionic InRelease [7096 B]
Hit:2 bionic InRelease
Get:3 bionic-updates InRelease [88.7 kB]
Get:4 bionic-security InRelease [88.7 kB]
Get:5 bionic-backports InRelease [74.6 kB]
Get:7 bionic/main Sources [1187 B]
Get:8 bionic/main amd64 Packages [3233 B]
Get:9 bionic-updates/main amd64 Packages [2127 kB]
Get:6 bionic InRelease [23.3 kB]
Get:10 bionic-updates/main Translation-en [421 kB]
Get:11 bionic-updates/restricted amd64 Packages [388 kB]
Get:12 bionic-updates/restricted Translation-en [52.6 kB]
Get:13 bionic-updates/universe amd64 Packages [1738 kB]
Get:14 bionic-updates/universe Translation-en [371 kB]
Get:15 bionic-updates/multiverse amd64 Packages [26.6 kB]
Get:16 bionic-updates/multiverse Translation-en [6792 B]
Get:17 bionic-security/main amd64 Packages [1782 kB]
Get:18 bionic-security/main Translation-en [329 kB]
Get:19 bionic-security/restricted amd64 Packages [365 kB]
Get:20 bionic-security/restricted Translation-en [48.9 kB]
Get:21 bionic-security/universe amd64 Packages [1131 kB]
Get:22 bionic-security/universe Translation-en [256 kB]
Get:23 bionic/main amd64 Packages [55.8 kB]
Fetched 9384 kB in 3s (2768 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 27 not upgraded.
Need to get 913 MB of archives.
After this operation, 70.3 MB of additional disk space will be used.
Get:1 bionic/main amd64 gitlab-ce amd64 14.0.0-ce.0 [913 MB]
Fetched 913 MB in 22s (41.0 MB/s)
(Reading database ... 127178 files and directories currently installed.)
Preparing to unpack .../gitlab-ce_14.0.0-ce.0_amd64.deb ...
gitlab preinstall: It seems you are upgrading from major version 13 to major version 14.
gitlab preinstall: It is required to upgrade to the latest 13.12.x version first before proceeding.
gitlab preinstall: Please follow the upgrade documentation at
dpkg: error processing archive /var/cache/apt/archives/gitlab-ce_14.0.0-ce.0_amd64.deb (--unpack):
 new gitlab-ce package pre-installation script subprocess returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
wget --content-disposition
--2021-06-23 23:50:28--
Resolving (, 2600:1f1c:2d4:8900:17a1:2e94:9f90:f91e
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: [following]
--2021-06-23 23:50:28--
Resolving (,,, ...
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 906414210 (864M) [application/x-debian-package]
Saving to: ‘gitlab-ce_13.12.5-ce.0_amd64.deb’gitlab-ce_13.12.5-ce.0_amd64.deb
864.42M   103MB/s    in 8.6s2021-06-23 23:50:37 (101 MB/s) - ‘gitlab-ce_13.12.5-ce.0_amd64.deb’ saved [906414210/906414210]
gitlabserver:~$ sudo dpkg -i gitlab-ce_13.12.5-ce.0_amd64.deb
(Reading database ... 127815 files and directories currently installed.)
Preparing to unpack gitlab-ce_13.12.5-ce.0_amd64.deb ...
/opt/gitlab/embedded/bin/ruby: /lib/x86_64-linux-gnu/ version `GLIBC_2.28' not found (required by /opt/gitlab/embedded/lib/
dpkg: error processing archive gitlab-ce_13.12.5-ce.0_amd64.deb (--install):
 new gitlab-ce package pre-installation script subprocess returned error exit status 1
Errors were encountered while processing:

Also earlier versions failing with the same error.

Thank you,


Hi @Daniel_ion
try to update the libc6 package first. I can’t find GLIBC_2.28 for Ubuntu bionic either. There seems to be only 2.27 available.

This error is usually when you try to install DEB package for a different Ubuntu release, but your link in wget is correct. It could mean the DEB is not packaged properly. You can try to raise an issue in the Omnibus issue tracker.