How do I transfer the project to groups with different permissions?

We now have multiple projects that belong to the same group, and all users belong to the same group. After dividing user permissions into different groups, how do I transfer the project to groups with different permissions?

thanks a lot!

Go to the project, then Settings โ†’ General โ†’ Advanced and scroll down almost to the end where Transfer Project is. Select the group for the new namespace and then click Transfer project.

Read the additional info in the transfer box as well about potential issues/problems you might encounter.

I have already tried it. But the result becomes this:

origin group\A
origin group\B
origin group\C

trannslate to (New group)

New group\origin group\A
New group\origin group\B
New group\origin group\C

The original project becomes a sub-collection of the new group. And I only transfer A, but even BCD is also transfer to the sub-collection.

This is I want:
new group 1\A
new group 2\B
new group 3\C

Can anyone please help me?

I think you are doing something wrong. I think you are doing it at the group level instead of at the project level. Now, here is how I simulated it on my test server. First I create two groups, suparu-old-group and suparu-new-group (I put your username in it so that you can see I did this for real), and then I created projects A, B and C and put them in the old group. Now, here is the first screenshot after I did this:

Screenshot 2022-05-05 at 09-47-29 Projects ยท Dashboard

now, I go to project A and then I followed my instructions so Settings โ†’ General โ†’ Advanced โ†’ Transfer Project. I then chose the new namespace or group which was suparu-new-group. Now this is how it looks:

Screenshot 2022-05-05 at 09-48-37 Projects ยท Dashboard

as you can clearly see, it only moved project A. Project B and C are still in the old group.

1 Like

wow , this is true!

Can you kindly provide a detailed screenshot of the [Transfer Project] process? I should have made an error here.

as you can see it clearly shows I have project A selected (top left corner). And all you do is select the new group.

1 Like

I just tested it and the demo website showed the same result as you.

But I am confused. I am quite sure that I also clicked transfer here at that time. Is there anything else that might cause this question?