"Invite group" as project Members option disappeared

Some time ago we could see “Invite group” option as members of project. Now option disappeared… so I can’t follow steps from documentation:

To share ‘Project Acme’ with the ‘Engineering’ group:

  1. For ‘Project Acme’ use the left navigation menu to go to Project information > Members .
  2. Select the Invite group tab.
  3. Add the ‘Engineering’ group with the maximum access level of your choice.
  4. Optional. Select an expiration date.
  5. Select Invite .

Because there is no “Invite group” tab now…

Any ideas please? Thank you.

That’s odd, I can see the Invite group tab in the usual place in my projects. If you log in via an incognito window, do you get the same thing?

Yes, unfortunately the same issue :confused:

Screenshot: https://i.imgur.com/9K8SqCG.png

What do you see if you click on Groups (6)?

I can just see the groups I previously added here using “Invite Group” option and can only remove those groups but unfortunately no option to add…

This is clearly a bug! It would be a good idea to either upvote an issue about this if there is one, or raise one if there is not.

I will. Thank you for responding me! Have a great day!

1 Like

Have you created an issue yet?
There is also Unable to add User as Project Member (#343741) · Issues · GitLab.org / GitLab · GitLab

1 Like

Hi All,

Is the issue resolved? Any further update?
I am also facing same issue: No Invite member/group option available for project created under any group/subgroup

Issue resolved by itself few weeks after issue appeard. Also the UI changed so probably some update solved this.


Hi @dominik.frankow,

  • Which Gitlab version did you use when the issue appeared?
  • Which Gitlab version did you use when an issue is resolved
  • Which version of the PostgreSQL database did you use?

Hi @dominik.frankow We have update the minor version of our GitLab which is 13.2.3-ee to13.3.2-ee but we are facing the same issue can you please suggest us if their is any other possible way to resolve this issue

Issue refence:

Hi any update?

I can simply see the agencies I formerly brought right here using “Invite Group” alternative and may most effective dispose of the ones agencies however regrettably no choice to add.

We are using GitLab 15.4 and I had the same problem. The button will appear if you disable the option “Projects in <group> cannot be shared with other groups” in the group of your project.

Still having the same issue with GitLab Enterprise Edition 16.1.0-pre (SaaS)


We are using Gitlab v16.1.2-ee and are facing with the same issue.

We want to invite a group to a project located into another sub-group for CodeOwners. The thing is the invite group button does not appear. The option “cannot be shared” is unticked. I also tried to create another root group but same issue.

Is there a fix ? Looks like the group invitation to a project is necessary for CodeOwners so i’m stuck. I can see groups already shared to a project in the past and can delete them but can no longer add new.

I’ve created a new subgroup and transferred everything to the new one, which somehow worked.

Maybe there’s some hidden value underneath all those cogs