Mishap in major upgrade, gitlab-ce not running anymore

Allright guys, I messed up big time and need help.

I tried upgrading my gitlab-ce instance manually because I missed a few releases and followed the guide on the manual upgrade paths, but messed up big time. I ran a 13.12.6 version and wanted to upgrade to 14.0.5, but accidentally typed in version number 12.0.6 and now I cant even upgrade it to a more recent version and neither can I successfully reconfigure it. Reconfig crashes on ‘bash[migrate gitlab-rails database]’ with STDOUT: rake aborted!

any clues on what I can do to make it run and upgrade again?

thanks for your help!

Do you have a backup? I suggest restoring it and trying again, you can use the Gitlab docs for backup/restore, and under /var/opt/gitlab/backups you should hopefully have the backup from 13.12.6.

I did NOT have a backup, however I managed to fix it, by downloading the .deb-package from my previous version, unpacked it, disabled the upgrade-check function, installed it over the messed up version, reconfigured it, and finally got it back up and running.

Maybe for the devs: integrade a downgrade-check function :smiley:

1 Like