Need help disabling 2FA after lockout

My 2FA device is damaged and I cannot seem to find where I wrote my alternative recovery codes. Is there a way to regain access to my GitLab account? I remember my login password, and I can still push to repositories (ssh).

Hopely, there is a way to disable 2FA momentarily so that I can switch devices. This should be a “ticket” support question but available docs recommend that I post here first.

Anxious for answers

If you uploaded an ssh key to your account you can try the command for generating new codes

ssh 2fa_recovery_codes
1 Like

Saved by @iwalker. Thanks a lot

1 Like

I have the same issue, except when I try to generate new codes I get : “ Permission denied (publickey,keyboard-interactive)”.

I tried writing to the support but since I only have a free account I only get automated responses suggesting to generate new codes… The only way to get my account back seems to subscribe to a paying plan (gitlab only accept to manually disable the 2FA when you pay), but I can’t subscribe for an account I’m logged out…

Do anybody have an idea ? I’m slowing going insane here…

Yes, this means you don’t have an SSH key on your account. This would have needed to have been uploaded before you got locked out.

Unfortunately, we cannot help you with your problem since we are only community members and have no access to Gitlab as administrators. Hopefully one of the Gitlab team would be able to help out, either here or via the support link.

Thanks for your answer ! I tried the support but they’re saying they can’t do anything for free accounts. I offered to pay but they just closed the ticket. Since I had to change phone and laptop, I have no copy of my code, everything I coded this last year is on gitlab… If anyone had an idea on what to do, that would be awsome