New server install

Hi all.
First of all apologies if I post this in the wrong forum.
I am setting up a new server.
I want this to have at least version 13 installed from scratch.
However when I follow the installation steps I end up with version 11.
It is probably something simple, but for the love of god I can’t find the correct install options.
When trying to upgrade from version 11 to whatever version I get the message version not found.
12.0.0-ee.0, 13.2.0-ee.0 etc, nothing works.
If somebody could help please that would be great.

What OS are you doing this on?

Are you installing from source or using the omnibus packages?

A possible explanation could be that you’re getting the version included with your OS, and not a version from GitLab’s repositories. Have you correctly added that?

Ubuntu 20.04
I haven’t seen any documentation about adding other packages before installing Gitlab
That’s information that would be very handy to have beforehand

Just to clarify, I followed https://about.gitlab.com/install/#ubuntu
This has no mention of installing a different version, pre-install other packages, etc.

I think I read somewhere that GitLab still doesn’t make packages for focal (ubuntu 20.04), that is probably what is wrong here. I believe there are some work arounds to install the package for bionic on focal.

Thanks Grove.
Support from Gitlab appears not to be the best.
In short:

  • Linux server: just about any, but not Ubuntu 20.04
  • Postgress: minimal version 11, but not 12 as that is not supported. So ONLY version 11
  • Puma web services, anything else won’t work

Will make some time this week to start all over again with a new VM and see what other errors I come across.
Any recommendations which Linux distro to use would be more then welcome.

I have no problems with the omnibus packages on older ubuntus (16.04 and 18.04). The plan was to look at replacing the 16.04 one with one running on 20.04 sometime this year, and I surely hope that focal packages will emerge.

With installing a new server, ideally you would want the latest version of everything.
That however is not possible yet :wink:
As I am not a Linux/Gitlab expert I was looking for this information but could not find it.