Omnibus MySQL to PostgreSQL problems


#1

Currently running CE Omnibus 8.13, trying to workout the upgrade path to bring our installation current.

First thing I am trying to do is migrate our DB from MySQL to PostgreSQL, but packaged gems are missing:

Recipe: gitlab::database_migrations
  * bash[migrate gitlab-rails database] action run
    [execute] rake aborted!
              Gem::LoadError: Specified 'postgresql' for database adapter, but the gem is not loaded. Add `gem 'pg'` to your Gemfile (and ensure its version is at the minimum required by ActiveRecord).

I also tried upgrading to the “latest” 8.x version of 8.17 first, but then ran into an issue with mysql2 gem missing.

Looking at the Gemfile and Gemfile.lock show that these gems are there, so what is the key to making this work?

Some other steps that I performed:

  • Updated Ruby to use 2.3
  • Installed Posgres 9.6

I have tried multiple times and different approaches, but keep running into gems not properly bundled in the Omnibus installation.